Naming conventions

Hey!

I come from a solid .NET background and I am working currently with lots of Typescript and Javascript. I know well the naming conventions for those two worlds but I would like some advice about Flutter, FlutterFlow and Dart naming conventions.

As far as I understand, there are some inconsistencies in FlutterFlow that blocks me from understanding what is the expected naming convention for all of the parts of the whole platform.

For example:
The Firebase tooling Creates a User(PascalCase) collection but also, when importing the chat component it creates chats and chat_messages (snake_case) collections so, which one is the correct one and mostly used by the community?

When creating a new page or component, FlutterFlow does not allow kebab-case in the name but I can rename my pages, widgets and components to kebab-case without any problem so, that feels like a bug to me.

Also, it doesn't allow a page/widget/component to end with 0 when you use kebab-case but it works fine if you use snake_case.

At some points in the FF use, it complains about naming conventions but it fails into following conventions itself!

I would like to get from the experts what are the most accepted conventions for:

  • pages

  • widgets

  • components

  • variables inside the FF UI

  • custom code

  • Firestore collections

FF should force us to follow the naming conventions or allow us to choose a specific naming convention to be used for the entire project.

12
5 replies